dwolla.com site unavailable
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 09, 2017 - 17:03 CST
Identified
www.dwolla.com is currently unavailable. We’ve identified the issue and are pushing a fix.
Posted almost 2 years ago. Jan 09, 2017 - 16:57 CST