The status of all previously affected RTP transfers has been successfully updated to reflect the correct status. Webhooks have also been sent to notify of these status changes.
Thank you for your patience and understanding as we worked to resolve this issue.
Posted May 12, 2025 - 16:05 CDT
Update
Our team is now executing the status updates for the affected RTP transfers that remain in a pending state. This process is underway, and we will provide a final update once it is complete.
Posted May 12, 2025 - 14:29 CDT
Update
We are continuing to work on updating the status of the previous RTP transfers that remain in a pending state. These transfers were affected before our recent fix, which has been successfully processing new RTP transfers since deployment.
While we don’t have a precise ETA for when these status updates will be fully resolved, this is our top priority, and our team is actively working to correct the status of these affected transfers.
Thank you for your continued patience and understanding as we work to fully resolve this issue.
Posted May 12, 2025 - 12:59 CDT
Monitoring
We have implemented a fix for the RTP status issue. All new RTP transfers submitted are processing correctly and are reflecting the appropriate status.
We are now working on updating the status of the 508 previously affected RTP transfers that remain in a "pending" state. We will provide further updates as this effort progresses.
Thank you for your patience and understanding.
Posted May 12, 2025 - 11:26 CDT
Identified
We are currently experiencing an issue affecting Real-Time Payments (RTP) submitted through our API. Since approximately 5:00 AM CT, these payments have been processing as expected — meaning that funds are being successfully transferred to the intended bank accounts. However, their transfer status remains "pending" in our system, creating a discrepancy between the actual fund movement and the reported transaction state.
The root cause has been identified, and we are actively implementing a fix to resolve the underlying issue.
Note: To avoid unintended duplicate payments, please refrain from resubmitting these transactions, as the transfers are still being processed correctly.
We appreciate your patience as we work to restore normal transfer status updates. Further updates will be provided as soon as they are available.