Dwolla.com, Dwolla Dashboard, and Developer Documentation are facing intermittent issues
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 12, 2018 - 09:35 CST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Nov 12, 2018 - 09:30 CST