Dwolla Dashboard and Admin is unavailable in Sandbox and Production
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted 11 days ago. Sep 07, 2018 - 16:34 CDT
Investigating
We’ve received reports of issues when attempting to login to the Dwolla Dashboard interface at https://dashboard-sandbox.dwolla.com and https://dashboard.dwolla.com. Users are met with a 503 error response. We’re investigating the issue and will provide an update shortly.
Posted 11 days ago. Sep 07, 2018 - 15:24 CDT