Intermittent high response times and timeouts resulting in Cloudflare 522 errors for small percentage of API consumers
Incident Report for Dwolla
Resolved
This incident has been resolved. The affected time period was from approximately 18:45 UTC to 23:45 UTC.

During this timeframe, we identified irregular API response times and Cloudflare 522 responses for a small percentage of API consumers on the platform. Upon identification at approximately 19:30 UTC, we immediately contacted our infrastructure provider Cloudflare to continue investigation. After further review from our infrastructure provider, the issue was ruled by them to be networking related which affected application that were running in the north eastern US.

We are working with networking provider to understand root cause and future preventative measures. We apologize for any inconvenience to the small number of consumers impacted. Please don't hesitate to reach out with any questions or concerns.
Posted Mar 12, 2020 - 20:10 CDT
Investigating
We are investigating intermittent higher than normal response times across the API for a subset of API consumers. We apologize for the inconvenience and will provide an update as we progress towards resolution. After review of data captured at the edge of our platform, intermittent errors began at approximately 1:45pm CT today.
Posted Mar 12, 2020 - 19:47 CDT
This incident affected: API - Production.