[Sandbox] Long Sandbox API response times and inability to log into Sandbox Dashboard
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted 22 days ago. Jul 26, 2019 - 14:18 CDT
Investigating
We are currently investigating this issue.
Posted 22 days ago. Jul 26, 2019 - 14:10 CDT
This incident affected: API - Sandbox.