[API v2 - Sandbox] Errors creating and updating non-US Beneficial Owner in Sandbox
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 18:13 CST
Investigating
We are currently investigating an issue with creating and updating a Beneficial Owner where passport information is supplied for non-US persons the Sandbox environment. Valid requests to supply passport information along with Beneficial Owner details are returning a 500 with a CommunicationError error response code.

Impacted endpoints:
POST /customers/{id}/beneficial-owners
POST /beneficial-owners/{id}

Example request body:
{
"firstName": "Jane",
"lastName": "Doe",
"dateOfBirth": "1982-12-24",
"address": {
"address1": "123 Main St.",
"city": "Test",
"stateProvinceRegion": "BD",
"country": "AF"
},
"passport": {
"number": "525698569",
"country": "AF"
}
}
Posted Nov 26, 2019 - 18:35 CST
This incident affected: API - Sandbox.