Experiencing issues retrieving some Customer resources

Incident Report for Dwolla

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 17:27 CDT

Identified

Since 103/27/2025 1:27pm CT, we have been experiencing an issue where retrieving customers by ID for Business Verified Customer Records in the Retry, Document, or Suspended statuses is failing. This issue affects both the Dashboard and API in Sandbox and Production environments. Our team is actively working on a fix, and we will provide updates as soon as possible. We appreciate your patience and apologize for any inconvenience.
Posted Mar 27, 2025 - 16:53 CDT
This incident affected: API - Production, API - Sandbox, Dashboard - Production, and Dashboard - Sandbox.