Issues with accessing the Dwolla Dashboard and Admin
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 24, 2017 - 14:29 CDT
Investigating
We’ve received reports of issues when attempting to access the Dwolla Dashboard and Admin (https://dashboard.dwolla.com). We’re investigating the issue and will provide an update shortly.
Posted 7 months ago. Apr 24, 2017 - 11:48 CDT