Degraded performance across all endpoints
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 13, 2018 - 19:24 CDT
Monitoring
The issue has been identified and a fix is being implemented
Posted 3 months ago. Mar 13, 2018 - 18:39 CDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Mar 13, 2018 - 18:36 CDT