Dwolla.com site unavailable
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted 25 days ago. Dec 28, 2017 - 14:43 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 25 days ago. Dec 28, 2017 - 14:05 CST
Investigating
Parts of dwolla.com site are currently unavailable. We’re working on a fix and will keep you posted
Posted 25 days ago. Dec 28, 2017 - 13:58 CST