[API v2] Experiencing intermittent issues
Incident Report for Dwolla
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 16, 2017 - 09:30 CDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Aug 16, 2017 - 09:23 CDT